Heads up pre-release-press release : WDTV G2 & WDTV Live ***updated4***

Hi Folks,

Sorry for no updates for a while. Its not because there hasn’t been any development, its because theres been so much development that I couldn’t get it to a spot where I could just let it sit and be happy…Well I’m there and will be fully publishing this release after I’m sure its good to go.

In addition to pointing you here I’d also like to point you here. The first link is to the forum post where I keep updates on latest versions and try to accomodate bug fixes. There you’ll find a snazzy new version of WDLXTV-LIVE, brimming with goodness and very stable. The second post is a release forum that deserves an h2 below.

I hereby release WDLXTV-G2 for the WD TV HD Gen 2 media player :D


WDLXTV-G2 includes all the goodnes that WDLXTV-LIVE-MINIMAL includes, in fact its identical :)

Right off the bat WDLXTV-G2 includes support for all the wireless adapters that the WDTV Live supports and a lot of wired usb ethernet adapters too. The list of supported drivers is as follows:

  • rt3070sta – usb wireless
  • rt2870sta – usb wireless
  • rt3572sta – usb wireless
  • rt2572 – usb wireless
  • arusb_lnx – usb wireless
  • rtl8712 – usb wireless
  • asix – usb wired
  • pegasus – usb wired
  • rtl8150 – usb wired
  • net1080 – usb wired
  • kaweth – usb wired

There is much to be excited about if you have a WDTV G2.

Now The first link was to WDLXTV-LIVE-0.4.1.7, which is chock full of bug fixes bugs and updates–sure to please :)

Heres the Changelog:

0.4.1.9-6
* includes derlinuxers index.php tweaks for dynamic webplugin loading into webend
* derlinuxer's S01ntp patch for static IP
* fixed /usr/bin/bandwidth_test
* fixed various osd backgrounds
* fixed USB_POWER_OFF=1 no osd.bin bug
* optimized wdlxtv.watch
* new /conf/ monitor
* logos for youtubeHD, shoutcast, & easynews in switchers
* new now playing overlay

0.4.1.9-4
* updated wireless-tools / fixed wireless adapters
* better detection of preferred wireless network
* updated live365 shoutcast proxy
* included eiri (allows remote control remapping and command execution)
* tweaked live365 pages
* updated wireless drivers to 1.02.19 version (no extra chipset compatability)
* fixed net.agent (WDLXTV-G2)
* updated NTP with static IP
* included iperf-2.0.4-5 & choekstr's bandwidth_test script
* optimized various scripts

0.4.1.9
* included Zoster's UMSP-0.1.2 media server (WDLXTV-Live)
*** includes Revision3, Shoutcast, Apple Trailers, BBC podcasts...
* included Mr_Miyagi's Webend (WDLXTV-Live)
* WDLXTV_LIVE-MINIMAL now includes lighttpd/php5-cgi/perl (default disabled)
* YouTube-switcher enabled (WDLXTV-Live) (requires LIGHTTPD=ON)
*** YouTubeHD : D (see S00custom-options) (WDLXTV-Live)
*** included rezmus EasyNews-proxy beta YouTube-switcher (WDLXTV-Live)
* patched several issues with WPA2PSK (wdlxtv-g2)
* fixed Deluge state dir (WDLXTV-Live)
* included live365-switcher (WDLXTV-Live) (requires LIGHTTPD=ON)
*** rezmus ShoutCast-proxy live365-switcher included (see S00custom-options)
* included fixed russian/italian/german translations
* fixed cifs-interceptor with NFSD=OFF (WDLXTV-Live)
* added rt2570, rt73, rtl8187 wireless drivers (WDLXTV-G2)
* fixed double mounts with media library disabled
* included ReMARKables netherlands translation (see S00custom-options) (WDLXTV-Live)

0.4.1.8
* fixed Samba (windows) exported shares & auto exporter
* added YouTube key saver (WDLXTV-Live)
* fixed cifs-interceptor (WDLXTV-Live)
* USB_POWER_OFF=1 works now (attached devices off during standby)
* CODEPAGE & IOCHARSET are used in mounting for non-english filesystems
* disabled ETH_xx_ACTION(s), replaced with POWER_xx_ACTION(s)
* re-included missing lighttpd & enabled lighty-enable-mod
* included mod_magnet & mod_webdav for lighttd
* tweaked 10,11,12 item list views
* included liblua5.1-0 (5.1.4-5)
* Switched NTP to default OFF (WDLXTV-G2)
* various script tweaks & bug fixes
* added ftp & zip binaries

0.4.1.7-1
* swapped smbtree back to matching version to fix network shares (WDLXTV-Live)
* added missing pam modules for ftp server (WDLXTV-G2)

0.4.1.7
* WDLXTV_G2 now available for WDTV HD Gen 2 devices
* added better system On/Off detection for turning off/on USB bus
* patched to show subtitle delay without audio channel info (thx rezmus)
* Deluge updated to 1.2.1-1
* included nfsd (kernel) NFS server
* new auto-export mode for Samba & NFSD servers
* Samba binaries from official fw 1.02.14
* Samba shares can be password protected
* NTP works with static IP & wireless now
* included all available NLS/codepage modules (see S00custom-options)
* XFS and ReiserFS drives now supported
* rezmus patch for custom fonts in OSD themes
* online-delayer now pings self instead of gateway
* Deluge auth file located at /conf/deluge.auth
* list.watch is now wdlxtv.watch
* fixed a few lib symlinks

NOTE: Some people have reported issues with connecting to windows shares from the ‘network shares’ area. It has been reported by multiple people, so if you are affected then you’ll have to stick with 0.4.1.0 or below until I fix the bug. If you’re affected, sorry, the software is under development. Please report bugs to The corresponding forum posts. fixed. :)

This is a work in progress under heavy development and managed/developed by myself. There is bound to be bugs, be sure to report them to the forums. You help out WDLXTV and all of its users by helping nail down bugs. I believe that 0.4.1.8 takes care of most of the bugs I’ve introduced lately.

** UPDATE ** 0.4.1.9 brings back YouTube HD, EasyNews xvid proxy, and shoutcast/Revision3/AppleTrailers!!! *** BUT *** Wireless adapter support is broken FIXED ;)

Read about WDLXTV-LIVE-0.4.1.9 here
*** a WDTV Live has serial # starting with WDBAA (has network port) ***
Get WDLXTV-LIVE-0.4.1.7 here
Get WDLXTV-LIVE-0.4.1.7-1 here
Get WDLXTV-LIVE-0.4.1.8 here
Get WDLXTV-LIVE-0.4.1.9 here
Get WDLXTV-LIVE-0.4.1.9-4 here
Get WDLXTV-LIVE-0.4.1.9-6 here

Get WDLXTV-LIVE-MINIMAL-0.4.1.7 here
Get WDLXTV-LIVE-MINIMAL-0.4.1.7-1 here
Get WDLXTV-LIVE-MINIMAL-0.4.1.8 here
Get WDLXTV-LIVE-MINIMAL-0.4.1.9 here
Get WDLXTV-LIVE-MINIMAL-0.4.1.9-4 here
Get WDLXTV-LIVE-MINIMAL-0.4.1.9-6 here




Read about WDLXTV-G2-0.4.1.9 here
*** a WD TV HD Gen2 has serial # starting with WDBAB (no network port) ***
Get WDLXTV-G2-0.4.1.7 here
Get WDLXTV-G2-0.4.1.7-1 here
Get WDLXTV-G2-0.4.1.8 here
Get WDLXTV-G2-0.4.1.9 here

More updates to come soon.

I keep forgetting to ‘launch’ it, but wdlxtv.com exists and will eventually be the new home for all wdlxtv releases. What does exist and is somewhat active right now is a wiki, that has some information. Anyone wanting to help contribute can sign up for an account on wdlxtv.com and let me know. ;)

DOdi
March 4th, 2010 09:08

i love you man . . great work thanks

serhan
March 4th, 2010 15:23

Thanks b-rad!

But can you please explain how we make the firmware change?

Because , although i sent 3 files(fff, ver, bin) , there was no big change in my wdtv. did i do something wrong? or should i change some files?

what are the other files(changelog, net.mount etc.) for? what are their functions?

you are a great volunteer. if you explain about these topics, i will appriciate.

<<< edit: If you have a different background now then you successfully upgraded ;) It is up to you to read the forums for tips and definitely read the files I’ve provided for information. –b-rad >>>

Tvrtko
March 5th, 2010 04:22

Tanks b-rad!

WD is realy stupid not to employ someone like you. You make the diference.

hosein
March 5th, 2010 11:15

hi
i updated from 1.01.77 to new firmware, but major problem of wd tv gen2 (that audio and video in some of mp4 dosnt sync ) not solved yet!!
this is very important for me because most of my movie was unwatchable!
can you explain me how can i fix this problem?

thanks

(sorry about bad english)

<<< edit: nothing to do with me, go bug WD. –b-rad >>>

Wiz
March 5th, 2010 11:28

Gen2?

I thought there was just a WDTV and WDTVLIVE.

All your previous wdtvlive updates worked fine…

I have = Model. WDBAAP0000NBK-EESN.

Crossing fingers its the Gen2!!.

<<< edit: WDBAB = Gen2. A WDTV Gen2 is simply the remake of the original WDTV, a WDTV Live with smaller specs and no built in network. –b-rad >>>

Wiz
March 5th, 2010 11:35

Ignore me, Re-reading, there are 2 WDTV versions
and Just 1 version of WDTVLIVE..

Its Friday night. Started the beers already..

xfighter11
March 5th, 2010 14:15

This update comletely crashed my WDTV Live. It does not boot up anymore. Only the known wallpaper appears and then nothing. What the f…? Pls help me. I’m so angry. Is there any possibility to go back to original firmware?

<<< edit: This should do the trick. Follow the directions in the README. If you want to go back to official, then place the official firmware release files on the device with root.bin and power cycle your wdtv live. Once it boots into the official firmware, select upgrade and it’ll upgrade using the official firmware files. If you need further help consult the forums. –b-rad >>>

Wiz
March 5th, 2010 15:00

some mp4 vids out of sync wintvlive also.

But maybe better encoding the vids :)

March 6th, 2010 02:13

Hello, Brad.
Since I upgraded I can no longer access YouTube:

1- I always get the ‘no contente available’ message
2- I can’t log in with my account

Can you help me ?
Thanks !

Jacopo

<<< edit: You need to reset the keys using an official firmware, then reflash wdlxtv-live. There is some sort of protection in generating them. –b-rad >>>

alex
March 6th, 2010 13:26

Hi Brad, i’ve been reading through the various postings and it sounds like my model of WDTV Live HD is not supported. I have (what I think) is Gen 2: WDBAAN0000NBK-00. When i try to use your latest firmware (1.01.24_B-RAD.CC_WDLXTV_LIVE_MINIMAL-0.4.1.7-1), it isn’t detected. Am I out of luck? Thank you.

<<< edit: There is only one version of Live. The WDTV Gen2 does not have a network connection. –b-rad >>>

arb7
March 7th, 2010 07:54

Killer release, thanks for the effort!

Some small feedback:
Perhaps it’s not supported on the WDTV HD Live but I can’t use the custom background image config command. The other ones work but if I try the custom one then it does nothing…(tried making the path to something in the attached USB device and even on the local operating system). Not a big deal but would be great to be able to customise the background.

<<< edit: just tested it out and works config_tool -c BACKGROUND_IMAGE=eM82_bg.jpg ? It does take 10-20s for the setting to stick, so don’t reboot quickly after setting. –b-rad >>>

Wiz
March 7th, 2010 09:08

My LAN connect drops out for no reason at all now.
Never had this problem b4, winxpro or win7.

Reverting back to previous update 2 double check.

Hope your previous update is still available for download..

<<< edit: previous versions are always available, everything doesn’t always work for everyone…there are some bugs in this version though which I’ve pretty much hammered out now. Just doing final testing. –b-rad >>>

Paladin
March 7th, 2010 13:03

Shouldn’t the live retain the name you have entered for it in the settings (default “wdtvlive”) instead of suddenly using a new one (default “wl-01″)

<<< edit: do you mean when you supply the custom smb.conf, which i provide? I can’t find wl-01 anywhere except there, next version I’ll make it xxxHOSTNAMExxx and dynamically set it. Coming soon. –b-rad >>>

James W
March 8th, 2010 02:15

Hi B-Rad,

Thank you SOOOOO much for wroking hard at improving an already fabulous product.

I bought the Gen2 WDTV yesterday, so am already excited about getting it hooked up with a wired adapter and your firmware.

You rock!

cbscpe
March 8th, 2010 02:35

Hi Brad,

thanks a lot for your great work. This weekend I spent some time to analyze my NFS performance problem I have with the WDLXTV firmware but not with the debian version. I thought the results might be of some interest to others as well. I’m now the owner of a small Linux system I could check against and tests showed that NFS Performance with both WDTVLive custom firmware had no problems with the Linux (Ubuntu Karmic) box. However even the newest WDLXTV firmware had serious performance issues with NFS of MacOSX 10.5 and 10.6 (less than 2Mbyte/second throughput). I tried various parameters and found that using TCP instead of UDP fixed this issue (net throughput with TCP is now 77Mbps, compared to 89Mbps using UDP against the Linux Server). So finally I can again use the WDLXTV firmware, which includes all the new features/fixes. Perhaps someone has an Idea why UDP performance is so poor and TCP performance is good. I would really like to know the reason.

<<< edit: interesting findings, would be good on the wiki. –b-rad >>>

proove
March 8th, 2010 10:12

USB_POWER_OFF=1 doesn’t work for me in a WDTV G2… I don’t have bins or any other file that could interfere with the OS… I just removed the # in front of the line and rebooted (not by remote) the WDTV. Is there anything else I should do?

<<< edit: logic error in the shutdown script. The below commands work around it, either insert into S00custom-options & power cycle with attached or telnet in and execute manually.
config_tool -c DELUGE=OFF
config_tool -c NZBGET=OFF

–b-rad >>>

progreat
March 9th, 2010 04:05

I have wusb54gc v3 can you add this driver
please

joe
March 9th, 2010 05:24

WDTV GEN:1 Any updates think we will see for this one maybe i understand u asking for donations but a donation will come from me when i see a newer update and i bet more will do so as well !!

<<< edit: I work where theres interest and most importantly, what I’m interested in. This is a free time activity that takes up a stupidly insane amount of time, and unfortunately I’m not made of the stuff. Maybe some day I’ll win the lottery and can devote full time to personal projects, until then…As for neglecting WDTV-1, it just so happens that the Live is a much more pleasurable development environment and has a lot more interest in it atm. I do eventually plan on porting a lot of my script changes back to WDLXTV-1, but really once some bugs are taken care of there is nowhere WDLXTV-1 can go. There is only 5KB left in the internal NAND flash–thats not much room to play or add anything additional. The firmware is ‘done’, its all about app.bins on WDTV-1. –b-rad >>>

March 9th, 2010 12:25

Hi B-Rad

Thanks for the quick test and response as per below.

“<<>>”

…the above command works for me. It’s when I try using a ‘custom’ jpg then I have the problem as per your template config command below.

#config_tool -c BACKGROUND_IMAGE=/tmp/media/usb/some/random/location.jpg

So in my particular instance I entered the following and it didn’t change the background image:

config_tool -c BACKGROUND_IMAGE=/tmp/mybackground_bg.jpg

…couldn’t get this one to work. Really not a big considering how everything else rocks, but for what it’s worth just sharing the feedback

<<< edit: will try an arbitrary link, maybe that doesn’t work like it should. –b-rad >>>

March 10th, 2010 01:58

Hello Brad.
Installing the new official FW and restoring the default settings fixed the problem with YouTube, which previously showed no contents.
Finally, I installed WDLXTV-LIVE-0.4.1.8 and everything kept working fine.
You were right: it must have been the keys…
But I still can’t log in with my user account, which works perfectly well on my PC. Do you have any clue ?
Thanks !

<<< edit: zero clue. –b-rad >>>

March 10th, 2010 05:34

Who do we need to sleep with and pay large amounts of money to, to get Movie sheets working (or ported rather) with the WDTV Live. Will so round out the firmware when that works one day.

Can’t we outsource this to the Indians or something

<<< edit: its no porting, its a complete rewrite to work around architectural changes that simply make it impossible for movie sheets on the live the way they’re done on the WDTV-1. Go find someone to outsource it to. –b-rad >>>

nik
March 10th, 2010 09:00

i know u keep gettins asked this but is there anyway u can fix this displaying the jpg as well as the avis in network mode, as u seem to be extreamly talented int fixing this firmware.
gr8 work by the way

<<< edit: I could, but its not worth my time or effort as it’d be quite a workaround. –b-rad >>>

arb7
March 10th, 2010 13:23

Who would be the best person to speak with around the Movie Sheet work(LuarentG, Titi, you?). Is it a case of just work not done/priority or actually the tech legends like yourself have still to work our a possible solution on the new architecture of the WDTV live (any good places in the forum where this is being discussed?)

It’s a privilage most of this stuff gets done for us for basically free by you guys. But if there was enough interest from ‘live’ people for this great feature of movie sheets then maybe a pool of money could be put up for the job etc….just needs some lobbying and coordination I guess. Shit if I had the skillset to do it myself I would but the noob force remains strong right now.

<<< edit: Those guys didn’t (no offense to them) pioneer anything about movie sheets. They used elmarwebers software to script movie sheets into existence. It will take either me or someone else a LOT of time to develop a new method that’ll work on the Live. Moviesheets don’t really interest me, so theres zero motivation here–realistically you’re probably talking at least a grand to get me off doing exploratory research&programming to hopefully nail it down once and for all. Its not exactly trivial. –b-rad >>>

Juan
March 10th, 2010 16:25

Hi,
thanks B-Rad for your effort!

I install the lates version of the firmare for WD TV Gen 2 (no live) v0.4.1.8. I have a performance issue using a rt3070 usb-wifi card. If i use the rt3070 on my notebook, streaming video from a WD HD world edition, i can see videos at near 4000 kb/s bitrate (mkv H264). But if i try with the WD TV G2, any video under 1000 kb/s run with stop gaps.
Please, i’ll apreciate any help on this issue. Thank you!

Juan

<<< edit: Ask on the wdlxtv forums. –b-rad >>>

mm
March 10th, 2010 22:36

Tried this firmware, but it went really wrong.
Tried to go back to the officiel firmware, but now the box is dead. powerbutton is flashing but nothing more is happending. Tried to unplug everything but no luck.
Have to RMA it.

BVG
March 11th, 2010 08:04

Like Joe, I wish to have a new firmware to WDTV Gen1. I miss a client torrent with no errors (I use rtorrent + wtorrent, and have a lot of cannot alllocate memory issues)… but maybe this is not possible, or is?

Regards..
Continue the good work ;)

<<< edit: The device has 32MB ram and no swap. Memory issues are to be expected. A torrent client will never fit in the firmware, the entire firmware is 13.5MB and there is only 5KB left! Get a WDTV Live if you want better performance and built in functionality. –b-rad >>>

BVG
March 11th, 2010 09:55

Thanks.. I will think about it ;)

Rockcrawler
March 12th, 2010 12:04

Awesome work on the Live. I have been searching for an answer to this for about a week and I can not find anything. Is there a way to change the port number on the lighttpd installed on 4.X? I cannot edit the config file because of the read only filesystem, but I thought there may be another config that I could edit.

<<< edit: create your own conf file containing server.port = XXX, then symlink that file into /etc/lighttpd/conf-enabled before lighttpd starts. –b-rad >>>

Rockcrawler
March 12th, 2010 21:37

Thank you very much for your quick response. It works great now. Expect payment soon!

March 13th, 2010 14:47

I have a problem, my Wireless adapter is D-Link DWL-G122 802.11g Adapter [ralink rt73], I see that it is not at the list of supported adapters, is it going to be added or i must find another…

biggest problem is that I don\t have a clue what to do, to attach mu WDTV G2 to mu home network…

joe
March 14th, 2010 09:14

thanx for the info brad i just bought me a wdtv live becuase of ur response looool wife hates you but me i love ur work so i went and bought this bad boy thanx

BVG
March 14th, 2010 13:03

lol.. the same here, joe.
this week I’ll receive the wdtv live.
I wonder if I can share the USB disks connected in WDTV live to my home network. I would like to put my old WDTV (1Gen) on my bedroom, and get content via my home network.

Regards from Portugal.

NHE
March 15th, 2010 00:43

Hi, is there a chance to get a Belkin Gigabit Adapter (F5D5055) to work with a G2? Doesn’t get an IP.

Thanks

March 15th, 2010 05:38

Just installed WDLXTV-LIVE 0.4.1.9, everything works fine, except the UMSP server, which I can’t find through webend.
http://myip/umsp didn’t work either.
Was the umsp integrated in your firmware (that’s what I understood) or do I have to download it and copy it to a permanently plugged in USB stick?

Thanks for your great work, as soon as I know my WDTV better, money will be on it’s way :-)

<<< edit: telnet in and execute: config_tool -c UMSP=ON. –b-rad >>>

Janito
March 15th, 2010 10:29

Hey All,

I was just wondering if someone could be so kind to answer the following question. I have 3 HDDs connected to the WD player. Two are through a USB hub and one is directly connected to the player. Why is it when I want to watch a movies all 3 HDDs show up, but when I am in the File Management part of the player only 2 HDDs show up? Thanks in advance.

Regards,
Janito

PS: Great firmware BTW

Juan
March 16th, 2010 08:31

Hi,

i install 0.4.1.8 firmware and i have a performance issue connecting to a NFS file share. I read the comment made by cbscpe. How can i change from UDP to TCP? Thanks!!

enko2974
March 17th, 2010 00:51

Hello,i have wdtv live,and i wanna ask is there some chance to implement 5.1 sound in the player,because that is the only thing that is missing.
And to read DVDRom tru network from my PC.

Thank you and good work

<<< edit: lol what? wdtv live plays 5.1 sound and you can share any device you want over the network. Consult the forums for additional help. –b-rad >>>

Ste
March 19th, 2010 07:20

Hi B-rad, thank for you work!

I have WDTV gen.1 and xp sp3 with 3 disk in sharing. I would to configure a NFS sharing for WDTV (with Windows NFS Services for Unix), but it works fine only with disk fat32 formatted. Disk in NTFS see empty.
Any solution?

Thank you!

<<< edit: Asking for help in a WDTV-1 forum and not as a comment on a WDTV Gen2 / WDTV Live page would be a good start to a solution. –b-rad >>>

Mark
March 19th, 2010 10:32

Hi. I’m guessing this has probably been answered before, but does anybody know if the official Gen 2 firmware can be used on a Gen 1 box? Thanks.

<<< edit: absolutely not. –b-rad >>>

arb7
March 19th, 2010 21:29

Any ETA on 4.1.10 with wireless support :)

<<< edit: Making money to survive comes first, free time development comes second. It’ll happen when it happens, refer to the forums for up to date information. –b-rad >>>

p41
March 20th, 2010 22:18

A little off topic, but would it be possible to add a link to truecrypt in the opt section. Search for the link, it works fine, I show md5 of 15ba3833eb60d68440da476b65ceb60d.

<<< edit: excuse me, but I’m not searching for anything ;) You can provide me directly with any links you’d like to me inspect. –b-rad >>>

henka
March 22nd, 2010 01:39

Would it be to much to ask you to fix the dlna feature on your firmware? Atm if you select “play to” and select the WDTV on a movie in for instance WMP 11, you get sound but no image. Same for pictures. The movie plays (you can se parts of the movie if you jump out and in of a movie on the USB).

This “play to” feature is a part of DLNA and works with the latest official firmware, so now if i want to se a movie that i have on my computer i just right klick it and select play to and the WDTV, a sec later it plays on the player just as it would if you had a local file.

I know you are a linux person but this is nothing fancy for MS specificly but a part of the dlna specification and thuss should be supported by any dlna compatible software that has the function. This essentialy makes the WDTV a media extender for music, video and photos.

Have a look, it just seemse like the movie dont get priority and shows up on the screen.

Other things fixed in 1.02.14 version is better networking (samba i guess, no more dropouts playing files) and better control over subtitles (size, bordersize (more then just small/thick) and other things).

Ps. If you have problems with “wrong password or username” when useing a windows machine, uninstall Windows Live Sign-on Assistant. This program is installed with Live Essentials / MSN and breaks the networking for WDTV. This is a problem with latest official 1.0.1.24 ASWELL the “new” beta release 1.02.14. Ds.

Thanks for the great work mate!

<<< edit: DLNA issues are nothing to do with me. How about you play a pic first, then your movie. Discuss further on the wdlxtv forums. –b-rad >>>

Dembonez
March 22nd, 2010 11:10

I’ve been playing with this for a few days now, and I’m trying to find some info on activating/using python. Primarily, to port some of the python scripts developed for XBMC on the xbox.

I’m happy to put in the time in trial, error and blood, but the first bit requires some way to access the python stuff. Any thoughts on how I’d do that?

BTW, running 0419 – live, but I’m not yet running the EXT3 setup. from all I’ve read, it appears I’ll need to re-flash with the official firmware and go from there.

Thanks for the awesomeness, B-rad and all who toil with this fun little box.

Raj
March 22nd, 2010 15:05

Hi,
Does any of these updates are going to open and play internet tv?

Thanks in advance for your help

<<< edit: I don’t know, can you program? If so theres nothing stopping you from coding UMSP plugins. Ask on the wdlxtv forums. –b-rad >>>

Kiskakas
March 23rd, 2010 01:07

Hi B-rad,

First of all thanks for all the work you have done!

Among the supported ethernet adapters you mention that “asix – usb wired” is supported. Does it include “Trendnet (TU2-ET100) 10/100Mbps Ethernet Adapter” with ASIX AX88772 Chipset (the FW for Gen1 device supported it – so I guess it should as well)?

Thanks once again.

Kiskakas

p41
March 23rd, 2010 18:12

http://wdtvforum.com/main/index.php?topic=1026.0

gives the following link:

http://www.ip-phone-forum.de/showthread.php?p=1040928

I retrieved truecrypt and it worked fine on my WDTV. If there were a way to communicate privately I’d shortcut the [german] web site.

<<< edit: There is no cross binary compatiblity between WDTV G1 and WDTV G2/Live, zero. –b-rad >>>

Reder
March 25th, 2010 09:32

I downloaded this last version.
Excellent, but I can not pass the password and the Deluge
also the File Manager, could help me.

I’m using the password “deluge” and “wdtv wdtv”

Reder
March 25th, 2010 09:33

I’m using the password “deluge” and “WDTV WDTV”

Rob
March 26th, 2010 01:03

Hi b-rad

Great idea, thanks. I have loaded the new version for generation 2 but I am unable to get the Belkin USB wired adapter (F5D5055) to work. Have tried dhcp and fixed IP with the ASIX driver. Blinding blue LEDS but no connection. Am I missing something?

<<< edit: Ask on the wdlxtv forums. –b-rad >>>

arb7
March 26th, 2010 22:44

I could kiss your right now, you fixed wireless and did a post on getting sheets working! Hero status! Paypal is about to launch in the country will make a contribution when it’s live

ExhorVI
March 27th, 2010 10:30

With this special B-RAD firmware, is it work with a hdd volume over 2TB, (ex: Drobopro 8X2TB, managed like a single volume partition of 16TB) ?

<<< edit: I don’t know, why don’t you plug it in and tell me ;) –b-rad >>>

Dave
March 28th, 2010 04:00

I’ve just bought a WDHDTV Gen 2 and I’m looking for a way to disable the audio channel information that pops everytime a video repeats. Is this possible with your hack?

mingaz
March 28th, 2010 13:55

Man, you are great!

Is it possible to add exFAT support to the firmware? It’s already in beta (http://code.google.com/p/exfat/) and it would come in handy for 4+ GB files.

Great work!

ExhorVI
March 29th, 2010 04:17

Because I have not yet purchased these hard drives, i investigue to know the opportunities…

Stilgar
March 29th, 2010 08:44

First of all, thanks for what you’re doing, it’s amazing ?

Is it possible to have by default, all the folders in thumbnails mode, and for example, just 1 folder in list mode ? (by adding a .list_mode file for example in the folder or add the name of the folder to a file) ?

Is this function already exists ?

@++

<<< edit: not currently. –b-rad >>>

JT
March 30th, 2010 07:33

I love the stuff that you are doing B-Rad. Great job! When you get the MSheets working, I will definately donate some money for your efforts. :)

I have downloaded and flashed my WDTVLive with your latest MINIMAL firmware (0.4.1.9-4) but am having an issue with turning off the USB POWER to my WD MyPassport USB HDD when I turn off (suspend) the device with the remote.

The only change I have made to your S00custom-options file is uncommenting ‘config_tool -c USB_POWER_OFF=1′. But it has no effect. I have power cycled the WDTVLive with this file on my USB Flash drive and the power to HDD is still there. I even telnetted into the box and issued the command as root. But no go.

If anyone would be able to help me get this issue resolved, I’d greatly appreciate it.

<<< edit: known bug in 0.4.1.9-4, fixed in current dev version. Will be posted tonight. –b-rad >>>

elliot
March 30th, 2010 23:02

hi I upgraded 1.01.77 WD tv hd generation 2. I need to downgrade it. Edited it with a notepad edit 1.0.77 to higher digit and it still wont detect it. I edited the ver file. what should I edit the numerals as any help

<<< edit: Ask on the wdlxtv forums. –b-rad >>>

Patyek
April 2nd, 2010 12:04

I update to WDLXTV-LIVE-MINIMAL-0.4.1.9.4 and after WDLXTV-LIVE-MINIMAL-0.4.1.9-6 but you tube is not working. What is the problem? Thanks Before.

<<< edit: Ask on the wdlxtv forums. –b-rad >>>

joseaio
April 9th, 2010 10:07

Elmar (eiri developer) tell me that eiri not supports WDTV Live. Can you replace with old/any other IR mapping software on WDTV Live firmware?

<<< edit: uhhmmm…what? Its in there and works just fine, there was nothing a recompile couldn’t address. –b-rad >>>

pp
April 9th, 2010 13:01

Hi b-rad,

First of all thanks and congrats for the amazing work you have been doing. I’ve flashed my WDTV G2 with WDLXTV-G2-0.4.1.9 and everything is running smooth. However, one of the main reasons that made me try your amazing creation was to get my WD TV working with myy wireless USB dongle (rt73), which I haven’t been able to achieve. I’ve read a lot of stuff about it in the forums, but nothing I do seems to get the led in the dongle to blink, just to start…Can you give me a hint?

Thanks and regards

<<< edit: Monitor the wdlxtv forums, I’ll be fixing this RT73 issue soon. –b-rad >>>

magic_gem
April 10th, 2010 22:13

0.4.1.9 stated
* added rt2570, rt73, rtl8187 wireless drivers (WDLXTV-G2)

Does rtl8187 work with WDLXTV-Live too ? If not, when can we get that support.

<<< edit: You can when they officially add it to the list of wireless id’s that the OSD will recognize as valid adapter and therefore register you being online. You use a non-supported adapter and you will have access to zero of the online features. –b-rad >>>

magic_gem
April 10th, 2010 22:47

Great going guys (& gals if any) on the b-rad team. Shall surely donate some $$ towards your effort.

I dont understand the edit to the question regarding rtl8187 above. I was thinking it would work for WDLXTV-Live.

In specific I am using a ENCORE USB wireless Adapter – ENUWI-G2 – this uses rtl8187 I believe.

BTW – THANKS a lot for fix = USB_POWER_OFF=1 now works. This is to tell “JT
March 30th, 2010 07:33″ that he can pull this change and it works.

joseaio
April 11th, 2010 10:22

B-rad, Eiri works fine with your WDTVLive?
Can you open a telet on port 14247 to see IR codes?
# telnet localhost 14247

You can see comments (7 to 10) of Elmar on:
http://wdtv.elmarweber.org/index.php/2009/eiri-r189-released-added-support-for-command-remapping-and-other-remote-controls#comments

Thank you B-rad

burbarian
April 13th, 2010 23:25

Hi B-rad. I have a G2. I just want to change subtitles font ( to bigger than 40) , colours and position on screen. Is it possible with this firmware? Thanks.

<<< edit: affirmative, consult S00custom-options after you install to find out how to enable larger sizes. –b-rad >>>

sirwimpyix
April 16th, 2010 05:43

Hi there B-rad! Do you plan tou release firmware based on official fw 1.02.21? The reason I’m asking is that I would appreciate the new shift exeternal subtitles up and down functionality ;-) Thanks for doing such a great job for all of us!

<<< edit: You should go check out the new homebrew forums. ;) –b-rad >>>

joseaio
April 17th, 2010 02:26

Eiri works fine on WDTV Live!!

On first telnet session type:
# config_tool -c EIRI=ON
# reboot

On second telnet session type:
# telnet localhost 14147

Use your remote to see codes on screen

D-Frob
April 22nd, 2010 14:54

Hello, I have a question!

I´m lsearchin in the www and I dont find a order for installing Msheet or Showcase for WDTVHD2G.
Can you tell me if it is possible at all to insert a movie preview in 2 Gen.
It would be very nice because I´m busy with it all the day and I dont have a result.

Thank you very much and I´m sorry for my bad english.
Great work

<<< edit: Ask on the wdlxtv forums. –b-rad >>>

max
May 15th, 2010 07:29

how to work rtl8187 on wd live? :(

<<< edit: If its not an officially supported adapter then it won’t work on wdtvl as the osd will not recognize there is a connection present. –b-rad >>>

mankidavu
May 18th, 2010 21:55

Is there any more updates coming on WDTV
G2 firmware with more wireless drivers included?
I’ve been struggling to get one ra2070 based usb adapter (wusb54gc v3).Also most of the guides on net focuses on wdtv v1.I’d like to see some developments on wdtv G2 as any new buyer gets that model now.

<<< edit: Join forum.wdlxtv.com and inquire there. If you want to stimulate further G2 developments, then you can always donate with ‘wdlxtv-g2 development fund’ as the comment. ;) I am not made of time and am extremely busy. –b-rad >>>

burbarian
May 19th, 2010 02:41

I have a G2. I downloaded “1.01.77_B-RAD.CC_WDLXTV_G2-0.4.1.9″. Everything is fine.Thank you for all. But subtitles are so close to middle of the screen. Is this possible to change position up or down? Or have you a working on this? Thanks.

Shazam
May 25th, 2010 02:02

Dear Mr. B-RAD,

I got a froozen WDTV logo G2 after trying upgrade to official 1.01.77. I am able to communicate with the unit using a RS232-TTL cable connected to the PCB. There I saw that “FW_SIGN= ” (which should be “FW_SIGN=okok”?).
Can you help me on this?
Thank you.

<<< edit: Not here ;) forum.wdlxtv.com –b-rad >>>

Alejandro
May 26th, 2010 04:52

Hi, where I can download the 1.01.77_B-RAD.CC_WDLXTV_G2-0.4.1.9 firmware? I can’t find in any links.

Regards.

Diogenes
May 26th, 2010 09:56

I’m having problems with MKV ripped with Handbrake. Some research says this is due to ripping with Variable Frame Rate which WDTV G2′s latest firmware doesn’t support. The MKVs play in sync and the video doesn’t stutter when played on the computer. It seems like this might be an easy patch. Thank you for all you’ve done.

<<< edit: If its an easy patch then you tell me how to apply it to encrypted & signed microcode files ;) –b-rad >>>

Riaper
June 15th, 2010 11:27

firmware to work with the hub (connecting two hard drive to a USB)??????
BOX 3.5″ SATA Vantec Nexstar NST-360MX-S2, 2xHDD, USB 2.0

Mark Wade
June 16th, 2010 18:02

Too funny. NO work is too hard for those who don’t have to do it.

Wayne
July 9th, 2010 03:11

Hi mate good site just a quick Q if i can can you plug a NAS into a WDTV media box via USB, or wirelessly to watch movie

<<< edit: I don’t know…You can either buy me a NAS so I can try or you can try yourself and tell me ;) –b-rad >>>

Asger Jensen
July 30th, 2010 22:06

Hi,

really nice work.

However, from a general user’s view (like myself), I’d say the only really advantage using unofficial firmware is AppleTrailers & MovieSheets.

I’d really like to see features like:
* Be able to stop a movie, and resume it weeks later (like on eg. the PS3).

Thanks for the efforts,
Asger

<<< edit: This functionality has been around for ages. You create a file called video_resume_point_table on an attached device and keep it connected at all times ;) –b-rad >>>

Michel
August 1st, 2010 09:48

Is the YouTubeHD problem fix in Ver. 0.4.2.0. You don’t mention it in your change log, but since it’s a easy fix…

<<< edit: No, but its fixed in 0.4.2.1 ;) –b-rad >>>

pH03N1x
August 20th, 2010 03:50

Thanks for the WDTV G2 support. Do you plan to add wired Moschip MCS7830 support into the G2 firmware?(i tried my moschip based usb ethernet, but did nothing) Wireless support is great, my Edimax EW-7711UAn working fine with rt3070sta driver, but i need wired ethernet support for highres movies.

Thanks!

Éamonn
September 13th, 2010 05:42

Hi B-rad,

I am hoping you could answer this. I know you are busy so i will try make it as straight forward as i can.
I recently bought a wdtv gen 2 media player running firmware 1.01.79. I want to upgrade to your custom firmware but i was having difficulty.

TonyPH posted the following on wdc.com forum:
“If your device shipped with 1.0.1.79, then you have different hardware (it now has an MCU in the hardware that controls power for EuP certification.) The 1.0.77 B-RAD code may not function on it.”

Can you confirm, the fact that i have this newer version of the player i am blocked from making any changes to the media player? Can you see an updated custom firmware being released down the line?

Éamonn
September 13th, 2010 10:02

Hi B-rad, I tried to post a message here earlier but it seems to have disappeared. I have just purchased a gen 2 wdtv player with the new 1.01.79 firmware on it. If I change the bar file that you created from 1.01.77 to 1.01.80 the upgrade icon appears. Now I haven’t attempted to change the firmware for fear I will brick the device. Do you think this will work if I do try it?

Éamonn
September 15th, 2010 03:29

Just to let you know, I successfully updated the 1.01.79 firmware to b-rads. I am not sure if there are any errors though because I have never seen it working before. Movie screens are up, but are very very hard to read. The writing is so small. This might be the tv though. Crappy little alba tv/DVD combi. 14″ screen.

Now that I have the firmware running what would you suggest as my next step. Besides buying a new tv. I am working on that. Is there anyway to make the writing on the movie screens bigger?

dennis
August 22nd, 2011 22:32

BRAD! Is there anyway I can go back to the original firmware? please email me. i badly want to flash back to the original. i tried doing this but your firmware is not looking for my usb drive (with the official firmware from wdtv). i need your help so bad,.

<<< edit: Sorry, but i don’t email anyone. You can find downgrade instructions directly on WD’s site. –brad >>>

marexon
January 22nd, 2012 10:33

Hi Brad, there are still more new mkv files unrecognizable by wdtv: after hitting the play button I got only black sreen, no playback, then the same issue with the rest of the files. WDTV can be brought back to the prev. state only with pluging it out from the wall-outlet. Could this be solved somehow in the near future? Thanx for your reply. M.

*Name
*Mail
Website
Comment