WDLXTV – enhanced WDTV firmware 0.4

WDLXTV is a souped up unofficial firmware for the Western Digital WDTV. It is based off of the brand new 1.02.00 firmware, but with many extra features. Similar to my dvdmod firmware, this is a permanent flash, just like an official upgrade. This firmware is an option for those whos hardware is stable with Zoranders ext3-boot, or those who don’t do much firmware programming to take advantage of ext3-boot. Once again, ext3-boot is for (sorta) pro’s and testers whereas WDLXTV is for everyday use.

Sorry it took me so long to whip this up ;)

Good stuff added:

0.4
* now based on firmware 1.02.00 !!!
* fsck_hfs is back in the firmware, no binaries have been removed this time
* thanks to DXR for reducing a handful of large OSD images to give me extra space : )
* fixed background back to Hardwood Night (after a mishap)





You may find the latest release at the WDLXTV page.

** WDLXTV-0.4 **

Don’t forget to check out the WDTV HD player unofficial firmware wiki.

I’ve spent a tremendous amount of time hacking the WDTV firmware, so if you appreciate my efforts please donate a little something using the link below : ) Thanks & enjoy.


Fredouye
April 2nd, 2009 00:30

“Your HD Media Player is being WDLXTV’d” :D

April 2nd, 2009 04:21

“now based on firmware 1.02.00″

this firmware evrsion… is the official one? on the WE Page there is only the 1.01.02 firmware…

<<< edit: I’m so fast as I was developing WDLXTV-0.4 I went back in time. 1.02.00 will hit WD’s site sometime soon. This is based off an official firmware release. –b-rad >>>

Jebus
April 2nd, 2009 06:38

The link:
http://root.unknown.sk/wdtv/wiki/doku.php...

Is kind of dead? How come…?

<<< edit: wiki changed locations to here, will change links around site today. –b-rad >>>

T
April 2nd, 2009 07:59

I installed the prior version and I FTP’d/Telnet’d into my WDTV over ethernet, which got me saying awesome! However, issues arose when I tried to play any media.

I’ll give this firmware a go tonight and see how it works.

Where exactly does the storage show up on the WDTV when your ftp’d to the device.

Are there plans to modify the OSD?

Hoping eventually that I can run a NES emulator on the WDTV.

<<< edit: your drives show up at /tmp/media/usb. I’ve modified the OSD & themed it, anyone can. –b-rad >>>

Hobbit112
April 2nd, 2009 16:22

b-rad,

I’m attempting to flash my WDTV with your f/w now and it looks like the box has locked up. I’m at the screen “Your HD Media Player is being WDLXTV’d. Please DO NOT dosconnect power or the attached storage.”

The upgrade bar has been at 0% for 20 minutes. The USB stick (fat32) flashes occasionally.

Any suggestions?

< << edit: try and use a FAT16/MSDOS formatted device. --b-rad >>>

Hobbit112
April 2nd, 2009 18:42

All is good now. Read the WD support & unplugged the WDTV. Box rebooted to past f/w.

Maybe had a bad d/l.

Did an update to the prerelease “official” f/w using a different usb stick which went well. Then loaded a new d/l of the WDLXTV on the new stick and update cdompleted.

Thanks again b-rad, your work is appreciated. I will send a token of my appreciation your way!

stoschnig
April 3rd, 2009 00:46

would it be possible to integrate a simple webbrowser? then i could handle my heating control via tv…

<<< edit: anythings possible. Will I be doing it? doubt it. You’re free to hire me to investigate other (actual) possible methods that you might be able to do this, but even then no guarantee at all. –b-rad >>>

Steve
April 3rd, 2009 03:12

First of all thanks for your great work b-rad!

I have successfully enabled NFS sharing on Mac OSX 10.5.6 and can successfully stream to WDLXTV using an Apple USB-to-Ethernet.

2 things I noticed :

- Continually scanning USB device
- Takes at least 10 seconds before streamed xvid avi starts playing after movie is selected.

Would you know what this might be please?

Regards,

Steve.

<<< edit: library db changed, so media library must be turned off & then back on again to get rid of the scanning. the ~10s wait is a ‘feature’ of the new firmware, its not me. –b-rad >>>

Jordy
April 3rd, 2009 13:49

Hi B-rad,

Really thanks for your update. Only found out one problem…

The background image of the submenu’s is gone…

Also, in a movie for example, when you press the ‘enter’ button to get the info screen, there is no background.

Is this only with me or is this just a modification you said in the release notes to free up some space?

And 1 other thing, I experience delay in the menu when I skip to for example from Movies to Music. Due to new firmware or is it just at me?

<<< edit: yes, some images were chopped up to save space. Due to uproar though they have all be placed back as original. Theres a 0.4.1 prerelease at wdtvforum with the images back as original and a few other OSD tweaks. –b-rad >>>

Jordy
April 4th, 2009 02:28

tnx b-rad! The 0.4.1 version works a lot smoother :)

Also, found out that DTS audio play without stuttering now! (don’t know if it’s fixed by you or WD, but it’s great!)

Steve
April 4th, 2009 02:57

Thanks I’ve got 0.4.1 working ok now.

Until they fix the long delay before movies start would it be possible to provide a download link for your 0.3 version so I my try it please?

Regards,

Steve

Daniel
April 5th, 2009 10:55

Hi b-rad, i think i have a glitch with your firmware v0.4, i installed it but now i cannot get rid of it… it won’t recognize any other firmware that i put on the usb stick. Normally it would launch the upgrade menu automatically but now nothing happens and i cannot change the firmware anymore. Any suggestions?

Thanks, Daniel

< << edit: I've moved around to different versions many times since 0.4 and theres been no issue. Have you opened wdtv.ver in a notepad and changed the version to 1.10? That should kick off an upgrade. --b-rad >>>

wilbert
April 6th, 2009 04:44

Hi b-rad i just did installed the custom firmware and bought an apple usb lan , the wd get an ip from the router , but i dunno what to do now :(

< << edit: now you go to wdtvforum and ask for help. Reading the firmware hacking wiki wouldn’t hurt either. –b-rad >>>

theslydog
April 6th, 2009 05:08

Yo B-RAD

Can u please put up the WDLXTV – enhanced WDTV firmware 0.4 based on the 1.01.02 firmware?

The 1.02.00 firmware has too many bugs.

I had to go back to std WD 1.01.02 firmware

Thanx

<<< edit: no, not worth the time and effort to maintain two seperate versions. –b-rad >>>

T
April 6th, 2009 07:27

What is the link to the 0.4.1 version?

Problems I have with 0.4.0
-takes long time for movies to start
-unable to go to about
-when clicking about the box locks up
-occasionally I have to power on and off as the device doesn’t seem to have any of the media read

<<< edit: try 0.4.2. It doesn’t solve the long delay problem but that isn’t me. WD will fix that soon. –b-rad >>>

BBS
October 20th, 2009 17:26

Hey b-rad, awesome work. I greatly appreciate everything you’ve done here.

I’m curious about how the WD TV indexes the media on external storage.
Is there any reason that a storage device could not be indexed before plugging it into the WD TV box? Scanning the drive on a PC would go much faster than the WDTV can manage, especially when dealing with 1TB+ hard drive sizes.

Any thoughts on the idea?

<<< edit: a binary called by the osd indexes shares. –b-rad >>>

Mike
May 12th, 2012 18:59

Hi b-rad
Kindly do something for WD Live TV Streaming media player Gen3 by making a comprehensive firmware.

June 7th, 2012 18:30

Kindly make an enhanced features firmware for my new 3rd Gen Western Digital Live TV Streaming Medial Player .Post it in this forum,please .I will appreciate for this kindness.I live in Canada

*Name
*Mail
Website
Comment