WDLXTV – enhanced WDTV firmware 0.4.3.2 — Fixed Link

WDLXTV is a souped up unofficial firmware for the Western Digital WDTV. It is based off the 1.02.03 firmware, but with many extra features. Similar to my dvdmod firmware, this is a permanent flash, just like an official upgrade. There is no Linux knowledge required to use WDLXTV.

Some errors creeped into 0.4.3.1, sorry about that, this maintenance release fixes them. Thank you to the people who pointed them out.

Seems I might have not zipped the release before I uploaded it, meaning not all the updates were contained. The zip has been fixed.

Ok, several people have pointed out that the upgrade is not being detected. I accidentally changed the version’ing scheme I used somehow. You can fix it easily using the method JT points out in his comment below.

It has been fixed in the version thats up now, so there should be no issue. Sorry about the bugs in 0.4.X so far, they’ve been mostly cosmetic at least.

0.4.3.2
* added more logging
* fixed typo in hotplugging script
* ext2/ext3/NFS/CIFS/XFS/reiserFS mounting fixed (for real this time).





You may find the latest release at the WDLXTV page.

NOTE: version numbering got messed up somehow in 0.4.3, if you have problems with the new firmware not being detected for upgrade you might need to open wdtv.ver in a text editor and change VERSION.

if this doesn’t work:

VERSION=’1.02.03_WDLXTV-0.4.3.2′

then try replacing the underscore with a dot or vice versa.

VERSION=’1.02.03.WDLXTV-0.4.3.2′

I will be going back to the original version’ing scheme (dot instead of underscore) for subsequent releases so if you upgraded to one of these versions you might need to change wdtv.ver on my next update. Sorry about the confusion, teaches me to package this stuff in the middle of the night.

** WDLXTV-0.4.3.2 **

Report any problems to the 0.4.X thread at wdtvforum.

Don’t forget to check out the WDTV HD player unofficial firmware wiki.

I’ve spent a tremendous amount of time hacking the WDTV firmware, so if you appreciate my efforts please donate a little something using the link below : ) Thanks & enjoy.


JT
April 10th, 2009 20:23

Hey,

I think you got the version number in wdtv.ver wrong. It wasn’t detecting the upgrade over 0.4.3.1 because instead of an underscore you put a .

Old version: VERSION=’1.02.03_WDLXTV-0.4.3.2′
New version: VERSION=’1.02.03.WDLXTV-0.4.3.2′

I changed the . to an _ and it worked fine.

JT
April 10th, 2009 20:26

Ooops sorry that was supposed to be

Old version: VERSION=’1.02.03_WDLXTV-0.4.3.1′

<<< edit: bit of a SNAFU happened, you’ll have to do the reverse of this next time around as I’ve corrected it back in line with previous versions. Thanks for pointing out. –b-rad >>>

Fredouye
April 11th, 2009 07:21

I’ve just had a problem flashing to 0.4.3.2, the update process was stuck at 41%…

After waiting a few minutes, I unplugged the box, which told me then to insert a disk containing a firmware :(

I’ve done so with a disk containing 0.4.3.1, and the box is back :)

<<< edit: be sure theres no .bin’s on any devices when you flash. I just flashed with 0.4.3.2 that is linked here (fresh 2min ago) and it went through successfully. What you saw is a scary message, but nothing to worry about. –b-rad >>>

mahen
April 11th, 2009 08:23

hey brad.i upgraded the firmware then inserted a empty fat16 usb disk and a 1tb ext3 hard disk. but it is forever showing the “scanning for attached USB device”…

any idea?

<<< edit: what version did you upgrade from? You might have to disable & then reenable media library to get it to stop. –b-rad >>>

Fredouye
April 11th, 2009 09:07

There was no other .bin file on my USB stick (I always use the same, which I format every time before flashing).

Anyway, my WDTV now runs 0.4.3.2 :)

BTW, your firmwares get better and better, many many thanks for your work !

<<< edit: good to hear things are working. Thanks for the thanks! Its nice to know my work is appreciated. ;) –b-rad >>>

mahen
April 11th, 2009 21:27

tried turning off and on media library…now scanning stops but it say folder are empty..it doesn’t recognizes my ext3 drive as i can only ‘safely remove’ my usb2(which is the fat16)…i think it still doesn’t see the ext3…

i appreciate your hard work…

i really wanna use this firmware…

Vainucleo
April 13th, 2009 22:13

First time with WDTV hacking for me, I have big issues with network connection. It gets the ip address once every 10 rebooting and even if it gets, it lasts for few seconds and then it loses the ip… This happens both with dhcp on and off. Any suggestion? Any way I can give you more information to solve my problem? 10x in advance

<<< edit: go to wdtvforum for general support, theres lots of help there. –b-rad >>>

*Name
*Mail
Website
Comment