WDLXTV App pack: pure-ftpd.app.bin-0.1

Heres another app.bin pack for use in WDLXTV, my custom WDTV firmware. The following pack contains the pure-ftpd ftp server, which was removed from WDLXTV-0.5.5+ because of size constraints. If you used the ftp server you’ll want this pack.


Simply download pure-ftpd.app.bin, place it on a harddrive/flashdisk & boot your WDTV with the device connected.

** pure-ftpd.app.bin-0.1 **


[...] pure-ftp server (requires pure-ftpd app pack) [...]

[...] pureftpd plugin, agar bisa transfer file langsung ke WDTV [...]

ET
July 14th, 2009 18:32

What’s the user id and password?

Thanks in advance.

Tane
July 15th, 2009 08:17

Can’t boot with pure-ftpd.app.bin on my storage device connected: blue screen, then the LED of the WDTV remains fix, but the start-screen vanished. Nothing else appened. I flashed with the latest WDlxTV firmware (0.5.5), I have a USB/Ethernet (compatible) connected, I can see the WDTV IP address but can’t reached the device from any computer.
Searching for help,
Thanks in advance

<<< edit: dunno. Perhaps your device has a hidden U3 partition on it preventing the wdtv from booting. –b-rad >>>

July 30th, 2009 18:59

Hey thanks for your great work on this stuff! I knew as soon as I saw one of these on the shelf that it would be a hackers dream!

I have flashed your most recent firmware, and loaded this app pack onto my ext3 formatted 500gb hard disk (also tried with NTFS and fat32 formats, same result).

I am using the trendnet tu2-et100 usb/lan adaptor hooked to a test lan that consists of a netgear router and one laptop computer.

I can telnet/ftp into the unit fine, but once i begin a transfer, it hovers around 4MB/s then after transfering about 150MB of data, the transfer slows to 0 and the box completly locks up.

I’ve tried it with a few hard drives and also flash drives, all formatted different ways. Any tips? I think I will try samba next.

<<< edit: I believe that adapter might be a problematic one. ASIX chipsets are the most compatible. –b-rad >>>

LKH
July 31st, 2009 10:11

Hi,

Can´t seem to get a connection to my wdtv using ftp. I installed WDLXTV 0.5.5 which works great, but i doesn´t seem like pure-ftpd.app.bin is installed. I do find it under /tmp/media/usb/USB1/E4FA-ECEE/pure-ftpd.app.bin when I telnet, but shouldn´t it be under /apps/? Is there a way I can boot/install it from telnet?

I´m a bit lost in this Linux world :)

<<< edit: the app.bin is mounted under /apps, so you’ll find /apps/pure-ftpd if its mounted & working. Additionally if you’re trying to upload to an NTFS partition you’ll want the directory preceded by a dot as the other is read only. –b-rad >>>

ToJa92
August 5th, 2009 07:00

@ET: It should be “root” (without quotes) as user id and nothing as password.

Shuka
August 8th, 2009 08:38

I am trying to connect a WD 250GB disk to the WDTV. I placed all the stuff I had on a stick before that but for some reason, on the disk the WDTV does not recognize the media and says that no disk is connected, although I can see the disk via FTP from my Mac.

I was hoping to use this disk instead of the stick. Is it possible?

<<< edit: dunno what your issue could be, disk or flash is all the same. –b-rad >>>

Fugazy
August 9th, 2009 08:15

Hi B-Rad
First of all, thanks for your amazing job.A really great firmware.
I use it with your pure-ftpd application. Just to know, do you made some test with this appli ?
I have some bad performance when I try to copy a file (4Go take over 7 hours … 350Ko max).
I use a Belkin Gigabit adaptor on my WDTV
Thanks again

<<< edit: are you uploading to an NTFS filesystem? if so it will be slow. –b-rad >>>

[...] Descarga | Web [...]

KC
August 15th, 2009 15:58

First and foremost I would like to thank you for all of your hardwork and dedication to making something good something great. I also humbly request some assistance with an issue I am having…

I installed 0.5.5 and got it working with and have an ip address of 192.168.1.8 for the WDTV. When I try to connect with a username of “root” and the pass left blank it refuses connection. I cannot figure out why it would do that. Any ideas?

A side note…which setup would you recommend for fast file transfers from my computer to the HD? I am on Vista 64bit…

Thanks very much in advance for any and all assistance!

<<< edit: Cheers. Some remote shell clients don’t like blank passwords, which windows clients do & don’t I have no idea because I’m not a windows user. I recommend NFS, if you can get it set up, how to do so you’ll have to look elsewhere because once again I’m not a windows user. –b-rad >>>

KC
August 16th, 2009 10:30

Thanks b-rad! Just wanted to let others know what the solution was to my issue…dirty drives. I tried a newly formatted pen drive with the pure-ftpd.app.bin-0.1 on it and it works like a charm!

Hope that helps someone else!

Fred Derf
September 1st, 2009 18:46

KC:
Thank you so much! I was having no success until I followed your example and reformatted my flash drive and copied the files to it. It started working!

Fred

Tristan
September 15th, 2009 16:42

Using a belkin gigabit adapter, I get good speeds uploading to my fat32 usb stick but abysmal speeds going ntfs hard drive. Would formatting ext3 help the speeds?

<<< edit: ext2/ext3 should be among fastest. –b-rad >>>

Jaque
September 27th, 2009 03:28

Thanks b-rad! Keep up the good work. I use WDLXTV with a wireless D-Link DWA-140. Everything is working fine including NFS support. I have just one big problem with the pure-ftpd application. I can connect with FTP to my WD HD TV device, but copying a large file always starts slowing down after having copied about 80MB/90MB of data to the USB device connected to my WD HD TV device and just seconds later The WD HD TV device locks up completely. The transferrate in the beginning is about 2MB/s. I tried different FTP clients, but the results are always the same. Pure-ftpd keeps crashing…

So I think it must be the Pure-ftpd application.

Anyone else experiencing this? I think Will had the same problem.

Jaque

<<< edit: haven’t heard this before, I don’t use the ftp to notice anything. If something is wrong I’ll look into recompiling latest version sometime. –b-rad >>>

Leo
September 28th, 2009 00:54

I’ve tried to set up the ftp, no problem so far but, i cant find the username and password. Username: root and a blank pw is not working, Thanks for your help

<<< edit: same password as you log into telnet/ssh with. –b-rad >>>

Leo
September 29th, 2009 01:11

Thanls voor your comment B-rad. The problem was my ftp-prog flashFXP. I,ve read the tip to put just one space in the password field and don’t use proxy. It is working great now. Also the webserver-bin. The only problem left is that i have no folders of the network (3 x xp) visual after booting up. The WDTV has an IP, wich is in the 10.0.0. range of my network. I have tried to set up the folders with the webserver and via telnet. When i trie to setup the pad in the webserver i get the worning message that the pad isn’t good. \\Pcname\muziek\. When is put this in the explorerfield the pc can make this connection and works fine. In the explorerfield stands this: file://///Pcname/muziek/. Can you tell me how to make the share folders visual?. Thanks anyway for your help!!

<<< edit: i don’t use the webserver and am not familiar with its errors & particularities. –b-rad >>>

Fredeuh
September 29th, 2009 02:01

I experience the same problem mentionned by Jaque

>> copying a large file always starts slowing down after having copied about 80MB/90MB of data to the USB device connected to my WD HD TV device and just seconds later The WD HD TV device locks up completely. The transferrate in the beginning is about 2MB/s. I tried different FTP clients, but the results are always the same. Pure-ftpd keeps crashing…

<<< edit: When I have time i’ll browse around for a newer version of pureftpd or something else. Suggestions? –b-rad >>>

[...] pure-ftp server (requires pure-ftpd app pack) [...]

Justin
October 14th, 2009 10:10

With this many people having trouble with the blank passwords, can the next release have a new default non-blank password?

<<< edit: maybe, will consider. –b-rad >>>

Reg
October 27th, 2009 08:59

Amazing bit of firmware.

Flashed, dhcp worked 1st time, logged into FTP with a single space as pword.

Let the fun begin! Thanks again.

giribu
November 23rd, 2009 17:28

Didn’t succeed at first…
It took me a while to understand what was the problem.
Use HD or usb disk with a name without spaces.

usb disk
or
My Book

are names that won’t work…

hope someone could use this tip

DaSandman
November 30th, 2009 12:13

I’ve just recently started having the same problem as Jacque and Fredeuh in that large FTP uploads dont seem to work any more.

I didnt have this problem before, could upload large (8gb) files at 3.4MB/s to the ext2-formatted USBHDD connected to the WDTV (could only get 350K/s when using NTFS – if you are having slow uploads I recommend reformatting to ext2, there are windows drivers so that you can read/write to it in windows too).

Worked fine with all previous WDLXTV firmwares, then al of a sudden started happening – I was using firmware 0.5.7.1 at the time (note that this didnt start happening with 0.5.7.1 – I was uploading fine for weeks using 0.5.7.1 till this started happening). Thought that it would be a good time to upgrade to 0.5.8.1 since I had sitting around but not had time to flash, but that had the same problem. Reflashing back down to 0.5.7.1 hasn’t fixed the problem either.

About to try ext3-boot0.9.2 now with 1.03.01 root.bin and see if that fixes it.

If you want any help investigating this b-rad let me know.

Thanks, DaSandman

Hegemon
December 18th, 2009 11:50

Hi b-rad,

This is quite an incredible thing you’ve built. I’m a *nix neophyte (I’ve fiddled with Cygwin, but predominantly operate in Windows), so I may be missing something simple. I copied the pure-ftpd.bin over to the USB key that I’ve put the firmware on.

I can telnet into the box fine, but Filezilla returns ‘Connection attempt failed with “ECONNREFUSED – Connection refused by server”.’ when I try to FTP in. Using telnet, I can see that there’s a /apps/pure-ftpd folder that includes a /bin/ (that includes pure-ftpd) and a /etc/ that includes a blank init.d.

However, when I use “ps”, nothing related to pure-ftpd shows. I then tried navigating to the /apps/pure-ftpd/bin/ directory and running “pure-ftpd”; it claims
“pure-ftpd: ‘/lib/’ is not an ELF file
pure-ftpd: ‘/lib/’ is not an ELF file
pure-ftpd: ‘/usr/lib/’ is not an ELF file
pure-ftpd: can’t load library ”

Is there something I’m doing wrong?

Thanks,

Hegemon

Hegemon
December 18th, 2009 12:01

Hi again,

Please disregard my previous comment; I was hasty in asking for help. A pull-the-plug reboot fixed the situation and now I can FTP in fine!

Thanks again,

Hegemon

Desi
December 24th, 2009 08:00

WDTVLIVE
Hi,

I copied all my addon apps including ftpd to root directory but none of the addons are running. I can’t ftp nor the webserver running. i do see list of apps under /apps directory.
I have tried 2 different usb key fresly formated to fat32 but none getting loaded.
I checked using ps | grep for ftp but nothing.

—SNIP—

<<< edit: You’re trying to run original WDTV binaries on the WDTV Live, which is NOT binary compatible. Half of what you’re trying to load comes stock as well. –b-rad >>>

Jaque
January 2nd, 2010 14:40

When using a FAT32 formatted USB HD pure-ftpd works just fine. No slowdown in speed as with a NTFS formatted drive. For a FAT32 filesystem the maximum filesize is 4GB, but that’s no issue for me. I prefer FAT32 over EXT2/EXT3.

fgladu
January 7th, 2010 12:38

Need help!
Can’t access my HDD via PureFTP!
Message is: Server said:
Can’t create directory: Read-only file system
Error -140: remote mkdir failed
The drive is formated HFS+ not journaled.
I also tried NTFS, the result is the same!
I have core-extras.app.bin installed on a USB Key with dropbear-ssh.app.bin and pure-ftpd.app.bin.
Only FAT USB keys seems to be mounted read/write!

Any ideas?

Thanks

<<< your HFS drive might need to be checked, they go read only on unclean mount. To upload to NTFS you’ll need to upload to the directory that starts with a dot. –b-rad >>>

Frank
January 12th, 2010 03:36

First of all: thanks for the great stuff you are providing!

I am having issues with the character encoding using the ftp server. While via telnet the folder is displayed as “Hörbücher”, via ftp client it shows up as “Hörbücher” and uploading files with umlauts does not work.

How can I set the encoding used by ftp server (I assume it needs to be utf8)?

Thanks

kebabinho
January 17th, 2010 05:27

Hi,

I can send files between my pc and the wdtv. The only problem i have is that after every 1mb or so that i tranfer, the transfer pauses for a second and then continues, and then pauses after the next 1mb is transferred. Have you come across this?

xaer0
January 31st, 2010 11:15

hey there, tried this firmware, i can’t get this work, it worked once, but i dunno why
i put the firmware + pure-ftpd.app.bin on the same usb (fat32), and then flashed the wdtv, it doesn’t work, even if the usb key remains plugged in, i still get this : “ECONNREFUSED – Connection refused by server”
i saw that someone had the same error, but cannot resolve it, i need more information about how this is working

please help me…

gerd
January 31st, 2010 16:36

Hi,
thank you so much for your great work.
I’ve a stupid question: is there a possibility to reset the password? I’ve changed mine, and can’t login anymore. Maybe a typo, don’t know. Is it possible to reset it somehow or do I have to downgrad to a official release and then install your firmware again?

Thanks in advance,
gerd

<<< edit: Reflashing won’t affect passwords and other persistent data. Try this, it will reset your password to blank. Ask for further info on the wdlxtv forums –b-rad >>>

JP
February 22nd, 2010 10:14

I was able to FTP into my WDTV Ver 1. without any problem then it stopped working (using ver 0.5.8.1). I tried reflashing but when I put in any flash drive or USB external disk drive formatted with Fat32 with pure-ftp on it the WDTV won’t boot. Blue screen comes up, LEDs light up then goes to static. This happens with or without USB hub. If I delete pure-ftp or if I plug in disk drive after boot occurs, everything works fine except can’t use FTP (of course). IP address is recognized.
Any ideas?

<<< edit: Sounds like your app.bin got corrupted, try and re-download. –b-rad >>>

Andruxa
April 17th, 2010 08:27

Hi there!

Thank you for the great firmware! I am newbie to the Linux world, nevertheless managed to get working usb wireless dongle d-link dwa-140(b2) (thanks to the forum where i found the answer) and pure-ftpd server using which i can upload stuff to my WDTV+WD MyBook. The only problem that pure-ftpd causing remote control not working during playback. Is there any workaround of this problem? Is there any other ftp server that might be used along with WDLXTV?

Thank you!

Andruxa
April 18th, 2010 14:56

Apparently pure-ftpd wasn’t a cause. Just added event-osd.app.bin to usb stick, which in the end seems has fixed remote control issue. Strange there is no any note about it!

May 10th, 2010 08:58

Simple fix for all of those who are having trouble logging into the ftp:

1. Connect via PuTTY telnet session (login = root)
2. Type ‘passwd’ and change the default root password to something other than being blank.
3. login as root with your new password via ftp, ssh, etc.

G-Man
May 25th, 2010 03:38

Hey All,
Have read of lot of comments above. I am having the issue with the FTP not running.
I have put the app.bin file on the root of the flash drive and rebooted several times. I am able to Telnet into the WDTV and have even changed the password for the root. With either firezilla or FireFTP I am unable to get an FTP connection to the WDTV. I have telnetted in and checked the /apps directory and the only file that it is there is the core.extras.bin file which I need cause the HDD is formatted in HFS.
How can I get the pureftpd.app.bin file to mount ????

<<< edit: For support go to forum.wdlxtv.com –b-rad >>>

Bob972
July 18th, 2010 22:18

IT WORKS! Thanks.

How fast is (the best or reasonable) transfer speed (I use FTP) from my PC to WDLXTV? I have Transcend USB 100Mbps card. My FTP transfer speed is 3,3MBps. Is it to low? How to improve that?

I have Win7 64 bit and cannot connect in explorer to WDTV, despite the fact that I have samba pack installed and see WDTV-… folder. I cannot connect to WDTV. (No) Username or password don’t suite????

Thanx

Roland
October 5th, 2010 12:23

Hey!

I am trying to get the pure-ftp server (which is included in your 1.02.21_WDLXTV_LIVE-0.4.2.6 firmware) running to share some folders of a connected HDD over the Internet, but I am running out of ideas how to solve it. FTP-Server is running and it’s possible for me to have access on the WDTV Live by root. For the configuration of the FTP-Server I need the pure-pw command, which is not available at the WDLXTV. Maybe someone can help about fixing this issue.
@b-rad: Thanks a lot for your great work.
Cu Roland

*Name
*Mail
Website
Comment